New Posts New Posts RSS Feed - Engine coolant sensor replacement?
  FAQ FAQ  Forum Search   Register Register  Login Login


Welcome to the Chevrolet Owners Club Forums!

If you're new here, please introduce yourself in the Newbies Chevrolet Forum, we have forums for each Chevrolet Model so please make sure you post in the correct forum.

Engine coolant sensor replacement?

 Post Reply Post Reply
Author
Violaplayer View Drop Down
Newbie
Newbie


Joined: 12 Feb 2018
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote Violaplayer Quote  Post ReplyReply Direct Link To This Post Topic: Engine coolant sensor replacement?
    Posted: 12 Feb 2018 at 6:12pm

Hi

I am new to this forum, hope someone can help.  Here is the situation, I have a 2012 Chevrolet Cruze (manufactured in Korea)1.6 petrol engine.

Problem:

A car with wrench inside light came on after I turned on the engine and it won’t disappear until I turned off the engine.

 

Background: 

I brought my car to the local garage for carrying out an annual service and also told them this issue. Firstly they believe this light indicates a regular service is required and they tried to clear the light after they have finished the service (they have changed all fluids) .  However, this light came back even after the service done.  So they said this is to do with the “engine coolant sensor”, they said it needs to be replaced.  I have done the error code scan myself, but no error code was found.

 

Questions:

1.   Has anyone also experienced this? if so is it true that this issue is due to a faulty Engine Coolant Sensor or something else?

2.   Can I change the Engine Coolant Sensor myself? I am worried if I would need to disconnect the battery or computer or any other device etc. before carrying out the work? as I am not a technical guy Confused

3.   Please refer to the photo above, is it the right location of where the sensor?

Thank you very much

 V

Back to Top
Sponsored Links


Back to Top
Victor View Drop Down
Senior Member
Senior Member
Avatar

Joined: 02 Feb 2017
Location: Scotland
Status: Offline
Points: 328
Post Options Post Options   Thanks (0) Thanks(0)   Quote Victor Quote  Post ReplyReply Direct Link To This Post Posted: 12 Feb 2018 at 7:13pm
I don't think that's your temp sensor. Your car has two temp sensors, one is lnear the location you highlighted but further down on the engine and the other is located on the radiator but at the opposite side. They are held in place by a single clip apparently (I've never done one) but see this Youtube video
2015 Antara 2.2 Manual 6 spd box
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.