Chevrolet Owners Club banner
1 - 9 of 9 Posts

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #1 ·
Hey all

I've just started getting a whistle noise somewhere in my engine bay.

Basically if I rev the car, theres only a little whistle but if I'm driving and the revs get to say 2000rpm, theres a really loud whistle sound (like a loud supercharger going off its head) only when I touch the accelerator..
If I let go, it goes away.
I got my mechanic to see if they could find it, there's no issue with intercooler hoses, no split pipes that he can see from the top.
I'm stumped. Only started when I shoved a trailer on the back.
Its got a new EGR Valve, new exhaust manifold gasket, new turbo gaskets,

Any ideas?
 

·
Super Moderator
Joined
·
7,566 Posts
Odds on is that there is a split or tear the the turbo hose (often near the bracket) which a cursory visual inspection from the top will not see.
Other cause has been reported as turbo vanes.
Plenty of previous discussions on file. Try the Forum Search tool to read previous similar topics.
Typically : Possibly a blown turbo!!!
 

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #3 ·
Odds on is that there is a split or tear the the turbo hose (often near the bracket) which a cursory visual inspection from the top will not see.
Other cause has been reported as turbo vanes.
Plenty of previous discussions on file. Try the Forum Search tool to read previous similar topics.
Typically : Possibly a blown turbo!!!
I've got plenty of power and there is no engine light.. its just a frustrating sound I seriously cant be stuffed dealing with lol.

Ill see what my mechanic says on Monday but hopefully its just something not too severe,
 

·
Registered
2008 C100 awd diesel
Joined
·
17 Posts
If its anything like mine, its the turbo...

Started whistling, with no apparent drop in performance. Only when the unit was changed, was the performance increase noticeable. Spool-up was faster
 

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #5 ·
If its anything like mine, its the turbo...

Started whistling, with no apparent drop in performance. Only when the unit was changed, was the performance increase noticeable. Spool-up was faster
Yeah don't know... hopefully mechanic will find it.. not sure if its worth worrying about and putting up with the noise either.

theres no issue with temp guage, performance, its just a bloody irritating noise lol
 

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #6 ·
I forgot to also mention that when the car is cold, it's fine but as soon as it starts to warm up, thats where the sound begins
 

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #7 ·
so took the car to the mechanics... did a few revs and some smoke coming around turbo, they got underneath and got a pipe and heard it leaking from the gasket behind the turbo..

ill keep you updated :)
 

·
Registered
2008 Holden Captiva 2.0L Turbo Diesel
Joined
·
10 Posts
Discussion Starter · #9 ·
I had the same issue last year, not turbo problem, no lack of power just strange whistle noise when accelerating. Can refer the previous thread.
yeah although doesnt matter how much I put my foot down, it is loud as

the only work i've had done was new manifold / flange exhaust gaskets and also a brand new EGR Valve.

when the mechanic was revving it, you could see with a torch and listening with a hose to see that it was a gasket.

getting it fixed on Tuesday.. they will double check everything again but they are very certain the gasket is knackered
 
1 - 9 of 9 Posts
Top