Chevrolet Owners Club banner
1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi there am new to this site as am currently running out of options.

I have a 10 plate captiva 2.0 liter [litre] ( Disesl) [Diesel]
It has lost all power now sitting in limp mode dosent [doesn't] want to rev over a certain amount and when this happens it dies dosent [doesn't] want to idle just stoles.[stalls]. Put your foot down to the floor ( accelerate ) it dosent [doesn't] rev straight away take a bit to register. And when driving it will just cut out.

I have had the DPF done, I've remap the car, had the EGR sorted exhurst [exhaust] gas and pipes have been changed n clean. Air low mass changed......
!!!!!!HAS ANYBODY GOT ANY IDEAS OF WHAT THIS COULD PLEASE!!!!!!

Thanks .
 

·
Super Moderator
Joined
·
7,658 Posts
Crazy Cars, Loss of Power is a regularly reported / discussed issue on this Forum. Use of the Forum Advanced Search Function will provide you with several hours worth of reading.
You have not provided any history of diagnostic codes which are a fundamental step for any possible trouble shooting progress on a modern vehicle.

I would suggest that you complete your Sign-Up World location (the Forum system believes you may be in UK?) and vehicle details in the designated sections (which you left blank), and then use the Search function and read up the existing Topics on Loss of Power (several under duplicated or similar titles).

Further help can be found in the following link :- Helpful Guidance Using the Forum
 

·
Super Moderator
Joined
·
7,658 Posts
Who diagnosed / recommended work on DPF, the EGR etc? The one thing which you dont appear to have considered or addressed is lack of sufficient fuel flow or pressure. Lack of sufficient fuel volume will impact on idle, lack of power, stalling, etc. This vehicle is 12 years old. When was the fuel filter last replaced?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Hi thanks.

It was our local garage in England, Sheffield
It was the one who put it to the computer which said intake air tem or mass or volume air flow sensor A circuit, particulate filter restriction.

I have done everything it said on the computer and when I plug it recently after the work done it come up with NO CODES!

fuel filter has been changed 3 time now I have recently been tolled that it might be injectiors ect. It really hard to describe the way it drives when it wants to. After about 5 mins it dosent want to move any were.

Just want some other people opinions on this as it mu family car.

Thanks
 

·
Super Moderator
Joined
·
7,658 Posts
You mention that you plugged in diagnostic equipment ("when I plug it recently after the work done") there were no codes.
Unless you or your mechanic or you use diagnostic equipment capable of reading GM codes you may not have true reveal. DIY home diagnostics are unlikely to read deep GM codes.
As for other opinions and discussions you can find dozens upon dozens of discussions on this topic. Use the Forum Advanced Search facility to access and read these.
You will find how to access and use the Advanced Search function as well as how to complete your Sign-Up on the following link:-
Helpful Guidance Using the Forum
 

·
Registered
Chevrolet captiva 2010
Joined
·
10 Posts
Hi mine was doing the same have u checked the littel black pipe that goes to the dpf under the car mine was split I put some dpf cleaner straight in to dpf and chopped pipe down reattached with jubilee clip or if its split you can use fuel pipe gave it a good run burnt of the soot and mine is ok now 3000 miles on hasent come back the pipes underneath split all the time you can see just getting underneath quite easy to get to but mine was in limp mode and was engine mangment light on
 

·
Registered
Joined
·
1 Posts
Hi there am new to this site as am currently running out of options.

I have a 10 plate captiva 2.0 liter [litre] ( Disesl) [Diesel]
It has lost all power now sitting in limp mode dosent [doesn't] want to rev over a certain amount and when this happens it dies dosent [doesn't] want to idle just stoles.[stalls]. Put your foot down to the floor ( accelerate ) it dosent [doesn't] rev straight away take a bit to register. And when driving it will just cut out.

I have had the DPF done, I've remap the car, had the EGR sorted exhurst [exhaust] gas and pipes have been changed n clean. Air low mass changed......
!!!!!!HAS ANYBODY GOT ANY IDEAS OF WHAT THIS COULD PLEASE!!!!!!

Thanks .
I Had a same problem a few weeks ago.
The problem is by the air flow. There is tree parts for this reason but probably it's by MAF sensor. Mass air flow sensor meter.
Or the other air flow controls of motor.

 
1 - 8 of 8 Posts
Top