Chevrolet Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi there, I am new to this forum and was wondering if anyone else had a similar problem. I have a this spark for the past 9 years and it has been really reliable. I have an issue where randomly the car will not start and the ignition won’t trigger anything. A simple car jump fix’s it, perhaps there a is a loose connection to the battery? It is hard to pin point the problem as it is random
 

·
Registered
Joined
·
85 Posts
When was the battery last changed? As you say a simple jump start fixes it. It could be the battery is at the stage of not holding enough charge to start the vehicle. Or that the vehicle has not had a long enough run(s) to fully charge the battery.
Have you tried checking the battery cables to see if they are loose? As you mention that "perhaps there is a loose connection to the battery"

Also you have not filled in your signature yet.
 

·
Super Moderator
Joined
·
7,112 Posts
Fully agree with member JMC. Battery can reach a stage where there just isnt enough 'oomph' to properly crank and activate the system of ignition. Also worth checking when was the key fob battery last replaced.

Dyl, JMC mentions completing your Sign-Up, in particular this includes your World location and full vehicle details. Helpful info using the Forum on this link:-
 

·
Registered
Joined
·
385 Posts
Wire brushing the battery terminal posts and the connections is the logical and cheapest place to start.
 
1 - 4 of 4 Posts
Top