Chevrolet Owners Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
71 Posts
Discussion Starter · #1 ·
Hello, I have this code P0101 that turns me on the yellow car icon with wrench when the accelerator is pressed to the maximum and when I am fully released downhill.
the MAF, the vacuum line, the particulate filter and the catalyst have been checked, everything looks ok, what to watch again.
 

·
Super Moderator
Joined
·
7,868 Posts
Nanone, There are numerous previous posts, some of which are accompanied with other diagnostic codes. Advanced Search function will list these posts .
P0101 on its own is very often a MAF issue but you say this has been checked (has it been cleaned or replaced or the connections checked?).
The other 'often cause' is airflow problems possibly involving a split in the air feed pipe or the air feed pipe collapsing (sucking flat) in very hot engine conditions.
See this link as an example and read entry #6
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #3 ·
Hello, I solved the problem with the P200a code
Changing the solenoid valves number 6 and number 8 in the diagram, replace with HOFFER 25183170.
After replacement I continued to have code P0101, MAF sensor, with power loss with yellow light light ignition with key.
Solved by setting MAF parameters again with professional scanner, very simple, three minutes of time.
Now the car is fine
 

·
Registered
Joined
·
71 Posts
Discussion Starter · #4 ·
Update, P0101 trouble code has come back, I replaced the MAF sensor, problem fixed, car is fine, no warning lights
 
1 - 4 of 4 Posts
Top