Chevrolet Owners Club banner
1 - 15 of 15 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,don't know if any body else has had this issue but I have a problem with my air bag light.My airbag light came on and I took it to Chevrolet and they reset it but never said why it had activated!it lasted about 3 weeks and has now come back on.
Has anybody else had this problem please?
Thanks for your time and response in advance
 

·
Registered
Joined
·
380 Posts
Which light, the instrument panel one or the one on the passenger side. If instrument panel, could be just going over a speed bump/pothole, for some reason lots of cars it is the wiring connections under the seat. have you shoved anything under the front seats. Must say have had no issues with my epica in that respect. If the one on the passenger side,have you put something on the seat as over a certain weight the passenger side light will come on if no seat belt. only seen one other posting about this for an pica and that went off after being cleared.

Happy motoring and welcome to the forum.

which model/engine/trim do you have?
 

·
Registered
Joined
·
9 Posts
I know it's an old thread, but my main airbag light on the cluster lights up every now & then, I just fiddle around with the cables under passenger seat & start engine again & it's ok.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Hi and thanks for that,I have tried that already and it worked for about 2 weeks.After that it came back on and has been since.I took it to my local chevrolet dealer and they reset it and it went off,I asked them what the problem was and they said they had no idea but it only last 4 weeks and it came back on!!!

Chevrolet Epica 2008 diesel
 

·
Registered
Joined
·
164 Posts
Seems to be a trend for warning lights coming on, mine has the MIL light coming on every now and again, I just leave it and it goes off on its own, lol
 

·
Registered
Joined
·
1,066 Posts
my main cluster airbag light has started coming on, sometimes it goes off, ive read the module is under the pass seat which i have to slide right forward and then back cos i carry a SEN kiddy in a car seat, he kicks the pass seat if i dont move the seat forward, have i caused the airbag light?

gotta get the OBD2 sender in today now!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #8 ·
There was fault with the loom under the passengers seat which I had to get the light switched off most months.
If they know there's a problem they should rectify it because it was costing me time and money to break off to get it sorted ˜¡
 

·
Registered
Joined
·
1,066 Posts
im out of any warranty by a country mile (59 plate/58,000) so its under the seat time!

i have a code reader of my own as soon as i can get it plugged in (bluetooth mini so it can stay in)



Edited by: Chevvychase
 

·
Registered
Joined
·
3 Posts
I slid the front passenger seatfully forward , then got in the back. There was an electrical connector visible not connected to anything. Felt under the seat found the other half of the connection clicked them together , hey presto. Surprisingly the connector was good quality and I find it hard to understand how it had disconnected itself but it must have been something rammed under the seat the done the dirty. Thanks for the advice. If anyone having intermittent problems the connector was yellow and near the door side. The trick would be to fiddle with it while someone watched the display as it is hard to see it while you mess around under the seat.
 

·
Registered
Joined
·
3 Posts
found a connection pulled apart under the passenger seat. Best way is to slide seat fully forward then climb in the back the connector is on the door side of the seat
 

·
Registered
Joined
·
3 Posts
fixed connector pulled apart under passenger seat. Push seat fully forward then climb in the back. Connection is then visible under seat at the door side
 
1 - 15 of 15 Posts
Top