Chevrolet Owners Club banner

1 - 16 of 16 Posts

Registered
Joined
4 Posts
Discussion Starter #1
Hi, my 2007 Matiz has the engine warning light on. I hooked up an OBD scanner and it found fault P0404. I know this is regarding the EGR Valve. I researched and it is advised to clean it out so I YouTube'd it. It shows a massive part being cleaned. I looked to replace the part and it is a tiny part that comes up online. Does this code mean that small part needs replacing? I don't know if this helps but when taking this part out it is very stiff and I think it should be springy? Any help would be much appreciated 馃槂
 

Super Moderator
Joined
6,700 Posts
Well done for doing some initial research. You caption asks what is the EGR. The Exhaust Gas Re-circulation valve allows 'blending' of some of the exhaust to be mixed with incoming air. This exhaust gas carries with it some oily fumes and carbon deposits which eventually clog up the EGR valve which in turn unbalances the intake.
Removal and cleaning of the EGR often avoids replacing it.
Code P0404 is to some extent simply generic and there may be various causes for its activation.
Sometimes a poor or corroded electrical connector can affect the EGR
The following link mentions more possibilities to check :-https://www.fixdapp.com/blog/p0404-code

The Forum system has identified you in UK although you dont appear to have completed your 'location' at Sign-up. Placing your vehicle details in your Signature footer enables this information to carry-over to every post automatically.
The following link offers helpful guidance finding your way around the Forum. :-
Helpful Guidance Using the Forum
 

Registered
Joined
4 Posts
Discussion Starter #3
Well done for doing some initial research. You caption asks what is the EGR. The Exhaust Gas Re-circulation valve allows 'blending' of some of the exhaust to be mixed with incoming air. This exhaust gas carries with it some oily fumes and carbon deposits which eventually clog up the EGR valve which in turn unbalances the intake.
Removal and cleaning of the EGR often avoids replacing it.
Code P0404 is to some extent simply generic and there may be various causes for its activation.
Sometimes a poor or corroded electrical connector can affect the EGR
The following link mentions more possibilities to check :-https://www.fixdapp.com/blog/p0404-code

The Forum system has identified you in UK although you dont appear to have completed your 'location' at Sign-up. Placing your vehicle details in your Signature footer enables this information to carry-over to every post automatically.
The following link offers helpful guidance finding your way around the Forum. :-
Helpful Guidance Using the Forum
Thanks a lot. I am in the UK yes.
 

Registered
Joined
4 Posts
Discussion Starter #4
Thanks, I have updated my profile. On idling the engine sounds as though going to cut off but it dont. And the pin in valve don't move, can turn it with star screw driver, and other part is super stiff too. Does anyone know where the sensor is located on this vehicle or any further help to pinpoint the problem
 

Super Moderator
Joined
6,700 Posts
To pinpoint the problem I'd concentrate on cleaning the EGR first....then you can verify if the sensor needs attention.
The signal from sensor may simply be spurious due to stuck EGR.

You've added location thanks, but Signature footer will be useful also so that all Forum members can readily identify the vehicle details at a glance without scrolling back to the first post - some of them wont bother to do that.
 

Registered
Joined
4 Posts
My bros and me not sure, thanks for any help to get him back on the road again, I've had the egr valve off, I thought the pin on the valve is supposed to easily push in and spring back again, this one is solid, it pushed in slightly but it's not springing back again, cleaned it all up and put back again. Anyone know if this valve is damaged and needs replacing as don't want to just chuck parts on it.
I also wanted to test the sensor with a volt meter, any ideas on its location.
Also when we search for egr valve on eurocarparts and ebay with the registration number it shows a different part, u open it up and it looks like a sim card shaped thing but a little bigger sticking out of it, doubt it's an egr valve, that's why the what's a egr valve in the heading was about.
 

Super Moderator
Joined
6,700 Posts
Thanks, all cleaned up but error code persists
Have you used scan tool to delete the old codes?
Codes can remain 'in memory' for a considerable time. Ensure they are deleted and then verify whether what you have are 'new' codes.
 

Super Moderator
Joined
6,700 Posts
My bros and me not sure, thanks for any help to get him back on the road again, I've had the egr valve off, I thought the pin on the valve is supposed to easily push in and spring back again, this one is solid, it pushed in slightly but it's not springing back again, cleaned it all up and put back again. Anyone know if this valve is damaged and needs replacing as don't want to just chuck parts on it.
I also wanted to test the sensor with a volt meter, any ideas on its location.
Also when we search for egr valve on eurocarparts and ebay with the registration number it shows a different part, u open it up and it looks like a sim card shaped thing but a little bigger sticking out of it, doubt it's an egr valve, that's why the what's a egr valve in the heading was about.
The EGR valve for Matiz (M200 /M250 engine variant) should look like the illustration on this link:-
I have no idea what you are describing as looking like a Sim card ?!

Avoid looking up parts by Registration number. Always use complete full vehicle details. I've just entered your vehicle details into Eurocarparts and this is what is listed:-
 

Registered
Joined
4 Posts
Yes I've deleted the old codes quite a few times now with ignition on but engine off.
As soon as start engine and shut it off, code pops back up, then when car starts moving forwards the mil light comes on.
 

Registered
Joined
245 Posts
Hi Roy the valve in the EGR needs to be free to move. It should push in easily and return under the action of a light spring. It should also be possible to rotate it easily using the socket in the pintle head. The socket will take a Torx style driver of size T15. What is the DTC [diagnostic trouble code] information? A stuck pintle would seem be the cause of the upset. Is it possible to attempt cleaning/freeing the valve again?
 

Super Moderator
Joined
6,700 Posts
Roy & Silly, Jasta is on the case now. He's the boy to work this through with you as he has a Matiz.
 

Registered
Joined
4 Posts
Thank you Ed and Jasta, went straight to eurocarparts after seeing the post, it's all fixed now, thanks for helping noddy getting his car back on the road. A new egr valve sorted it with your help.
Tried to hammer the pin back but stuck solid, doubt could of freed that one up.
Thanks again.
 

Super Moderator
Joined
6,700 Posts
R&S, Appreciate feed back on the solution. This will be of help to others in future. We'll mark this one up as a success.
 

Registered
Joined
10 Posts
For a P.S. I also have a 2009 Chev Matiz 1 litre SE (31,000 miles ).
Plugged into the diagnostic point is an AA Car Genie sender.
This on every journey reports error code P0404.
This states - EGR Circuit implausible Signal.
This suggests it is a fault in the wiring but it could be the actual EGR valve.
I have changed the valve, Cleaned it, Blanked it off with a plate all to no avail.
No engine light is on so for the last year I have ignored it.
I also have an engine rattle for the last 3 years, this also does not affect the performance and is
not related to the EGR valve as it is still there when the valve is removed.

Keep safe.K.Biddulph
 
1 - 16 of 16 Posts
Top