Chevrolet Owners Club banner

21 - 33 of 33 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #21 (Edited)
Sorry to missed lead...Injector which replaced 1 set (4 pcs) as well glow plug...just check fuse no 6 at front fuse box and check GP relay find send proper voltage to all 4 glow plug catridges...resistance also find same all four....
Cranking speed within speck.. Fuel pressure within speck...glow plug find working well..next step? Metered Air delivery system ?..its become so interesting and scratching my head
 

·
Super Moderator
Joined
·
6,445 Posts
Victor, Whilst I appreciate the data shown states 28C ambient, the OP does say this was recorded while idling. I cant see a time of day for this printout so could well have been later in the day.
The OP does say from the outset difficulty starting in the morning having been left several hours overnight. A morning temperature in some parts of the world can be considerably less which may necessitate glow start assist but rise later to warm/hot temperatures.
I know this from my days in the Middle East. Desert locations can be perishingly cold under canvas overnight yet reach 40+ C within a couple of hours of sun rise.
 

·
Registered
Joined
·
663 Posts
Ah, life in the desert Ed, yes. But you were too young to be a Fennec Fox, fighting under Monty in the Eighth Army against the Axis powers. What was it Churchill was supposed to have said about Monty? Indomitable in retreat, invincible in advance and impossible in victory. :)

But, agreed, there’s lots we don’t know about the OP’s situation but got a suspicion we might get drip fed some bits in due course.
 

·
Super Moderator
Joined
·
6,445 Posts
Victor, I wasnt building sandcastles in UAE, Oman, Yemen, 40+ years ago so no more to add. Look what the've done to Yemen! Sana'a is/was a beautiful walled city (Unesco listed)
I'm relieved you didnt back date me as far as Monty - that would make me a really ancient old fart and in my bath-chair.

Wait for more from Si Ario.
 

·
Registered
Joined
·
663 Posts
I think the only time I was in Saudi was for a refuelling stop in Jeddah on the way back from Australia so I don’t know anything about that area although I’m sure the history of it is interesting. During the Gulf War I remember them talking about it being the cradle of civilisation eg Mesopotamia, much of which is in modern day Iraq. The Epic of Gilgamesh was written by the Sumerians and it’s held to be a forerunner of the Hebrew bible with similar stories of the garden of eden, the serpent and the flood. There was a lot of hand wringing over the looting and destruction of precious artefacts in that area but that’s always the case where military invasion takes place..
 

·
Registered
Joined
·
13 Posts
Discussion Starter #26
well....EGR find working normal..its closed during cranking
the engine start in 2 dices:
1. Starting engine in 10 seconds -----no luck
2. Starting engine in 10 seconds with flooring Throttle pedal-----it's run
once able to run, it's easy to crank and run...
will try so start the engine with flooring throttle pedal tomorrow morning...what will happen
 

·
Super Moderator
Joined
·
6,445 Posts
Si Ario, We are now into page two of discussions. Anyone new joining this topic will have no idea as to the vehicle details under discussion. My early response to you (post #2) did provide you with User Guidance. May I urge you again to complete your 'Signature Footer' with your vehicle details. This way these details will appear under all your posts automatically for readers to see and identify without having to scroll back.
Helpful Guidance Using the Forum
.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #28
hi all,
this morning try to crank with flooring throttle pedal with 10-15 second and find no luck
its behave as usual need 10+ time to crank then run...again switched off and crank..within 2 second its run
cranking engine speed found 225 rpm,fuel rail pressure 24000 kPa, out side temp 26 deg C
 

·
Super Moderator
Joined
·
6,445 Posts
Only item which has not been 'replaced' by the sound of it is ..... the fuel. Lack of ignition combustion could be fuel related.
There could be an outside chance that there was a 'bad batch' of fuel below the required cetane rating.
If you can, try draining the existing fuel in tank and replace with new fuel along with possibly adding the equivalent of something like Millers cetane booster.
.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #30
hi all,
just drain fuel tank, replace Fuel filter and fill with 52 cetane diesel fuel with adding Liqui moly Cetane booster 1 can for 60L, clean Air Mass flow sensor with CRC cleaner....still no luck
 

·
Registered
Joined
·
97 Posts
Hi, just one thought: did you tried to start the engine with starting spray and check if there is a difference? If it a fuel related issue then the engine should start with starting spray immediately.
 

·
Registered
Joined
·
663 Posts
Possibility of faulty cam or crank sensor, worth disconnecting cam sensor to see if vehicle starts any better. If either one has been replaced with cheap aftermarket sensor it's better to fit genuine OEM parts. Even used OEM parts are sometimes better than pattern parts.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #33
Hi victor, Replaced with Genuine GM cam shaft sensor...still no luck its need 8 cranking time to run..after its run...imediate turn it off and re start,it's run within 1-2 second
 
21 - 33 of 33 Posts
Top