Chevrolet Owners Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
153 Posts
Discussion Starter #1
Has any member had this problem with their car. At the start of a return journey of about 40 miles my DPF indicator light came on, it almost immediately went off and the Malfuntion Indicator lamp came on. I continued driving and the car went into emergency mode ie. it wold only rev to 3700. On the way back the engine starte to rev freely again, however the MI lamp was still on. Later when I had to use the car once again the lamp stayed out after starting. It has remained out ever since. I think that the MI lamp is Chevrolets engine management equivilent. I will contact a dealer on Tuesday to find out if this is normal, however has anyone else had this problem?
 

·
Registered
Joined
·
104 Posts
Hiya, sorry can't help but will be interested to see what the dealer says. Good luck! How old is your Captiva nad how many miles on the clock?


Cheers

Rich
 

·
Registered
Joined
·
153 Posts
Discussion Starter #3
Rich
I have had it for 2 months it has done about 900 miles. Ithink that perhaps unlike any other engine management light problems which I have had in the past this one is meant to correct itself as soon as the problem is solved.

John
 

·
Registered
Joined
·
104 Posts
Ok, so you think it has sorted itself? Something to do with the DPF warning? Perhaps the run sorted out the DP filter and all is ok now? I'd never heard of these filters til recently and I'm not sure they're a good thing but all modern diesels have 'em and I believe they have to get up to a certain temperature to burn off all the sh*t produced by the engine so that we can all save the world. (That's not the most scientific explanation ever mind you! :) )
 
1 - 4 of 4 Posts
Top