Chevrolet Owners Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Dear All,

<br style="mso-special-character:line-break">After two days from Service Center for 35,000KM,
there is an "Vehicle Malfunctioning Light" indicator on my Captiva
(2007).

As per Owner Manual itwill
illuminate if a fault exists in the emission related components and we should
go for maintenance workshop as soon as possible if not it damage the vehicle.



Any one is facing with same issue. All your replies will be highly
appreciated




Best Regards,

Syed
 

·
Registered
Joined
·
476 Posts
This light is probably [DPF]particulate filter re-generation related, read some past posts on this issue. take the car for a run doing some reasonable speed and give the light time to clear. If it does not take the car to the dealer to get the codes checked and re-set the light.
 

·
Registered
Joined
·
214 Posts
I have had a continuing problem with this, the light comes on when I set the cruise control! I have had the codes reset, but has done it again. The car goes in on Monday for repair.
 

·
Registered
Joined
·
214 Posts
I have had a continuing problem with this, the light comes on when I set
the cruise control! I have had the codes reset, but has done it
again. The car goes in on Monday for repair.
 

·
Registered
Joined
·
652 Posts
John0 said:
I have had a continuing problem with this, the light comes on when I set the cruise control! I have had the codes reset, but has done it again. The car goes in on Monday for repair.

Ok, really stupid question I know.....but does the Cruise Control light come on.



I ask, because I had a similar problem years and years ago with a Vauxhall Cavalier GSi 2000. It was a company car, so I had no issues with giving it back to Vauxhall dealership to fix. It took them 6 months and they failed to fix it. In the end, a mate of mine had a look and found the electronics in the dashboard had a short, which lit the Engine Management Warning light whenever I flashed my High Beam. I had noticed the High Beam "Blue light" wasnt coming on, but the Warning light was, well I noticed, but didnt put the two of them together.



Now I'm not saying this is the fault, but if it lights evertime the Cruise Control is activated, surely common sense says it's something to do with the Cruise Control or maybe a short....



Good luck....
 

·
Registered
Joined
·
476 Posts
It can be the "CAN "wiring systems of modern cars a slight fault can bring the lot down. Needs a good auto electrician to have a look at it.
 
1 - 7 of 7 Posts
Top