Chevrolet Owners Club banner

1 - 7 of 7 Posts

·
Registered
Joined
·
652 Posts
Discussion Starter #1
Can we keep this thread clear of discussions and diagnostics (unless you 100% know the diagnostic), as I would like to collate all the weired and wonderful faults you may be experiencing on your Captiva.


The reason why, is I believe the Captiva has an inherent wiring fault, which Holden (Australian supplier of the Captiva under the GM badge) has recognised but Chevrolet UK will not discuss.



I would like to understand the problem you have experienced, when it occurred, how it was fixed if it was. Even if outside of Warranty as mine is, as if we can put this down to a known manufacturing problem Chevrolet will have to fix irrespective of the Warranty status.



Thanks all....
 

·
Registered
Joined
·
997 Posts
Perhaps whoever mods this site could place this as a sticky in the captiva section?
 

·
Registered
Joined
·
2 Posts
Mr Richards Very interested in your comments. My captiva , registered by chev 31 03 08 , bought by
myself on 28 12 08 with 231 miles on clock. Has been in Spain since then. recently dashboard warning lights on and loss of power. Has been in chev main dealer for 9 weeks with no definite solution. Chev Madrid & Luton are both saying they need to fit new wiring harness to see if it will be
the solution . It will cost me minimum of 2000 euros-- with no guarantee this will solve the problem.
Car has only covered 75000 miles - mainly on Spanish motorways.
If this is a known problem as you indicate , surely it would be in chevrolets interest to have problem
resolved. I have been in regular contact with customer services managers at both Luton & madrid. also trading standards uk, but to no avail ---YET !

David Spain
 

·
Registered
Joined
·
1 Posts
SEVERAL YEARS AGO i HAD PROBLEMS WITH WARNING LIGHTS COMING ON AND THE ENGINE
CUTTING OUT. MY VEHICLE WAS IN SPAIN , DESPITE REPEATED COMMUNICATIONS BETWEEN
CHEVROLET LUTON AND MY VEHICLE BEING OFF THE ROAD FOR OVER 10 WEEKS , NO SOLUTION WAS FOUND.
I NOTE THAT THIS WAS A COMMON PROBLEM WITH SOME 2008 / 2009 MODELS AND HOLDENS,
AUSTRALIA ACCEPTED THERE WAS A PROBLEM.
HAVE ANY OTHER CHEVROLET OWNERS CLUB MEMBERS HAD THESE PROBLEMS ?
I HAVE HAD THE PROBLEM RESOLVED , DESPITE CHEVROLET SPAIN WANTING TO FIT A NEW
WIRING HARNESS [ AT A COST OF OVER £ 2000 ] JUST TO SEE IF IT WOULD WORK.
I HAVE NOW GOT THE FINANCIAL OMBUDSMAN INVOLVED BUT I WOULD WELCOME ANY
COMMENTS FROM OTHER PEOPLE WITH THE SIMILAR PROBLEM AND IF THEY HAD ANY RESULTS FROM CHEVROLET
THANKSdavidspain
 

·
Super Moderator
Joined
·
6,624 Posts
David, I suggest that you also join and enquire on the Australian (Holden) owners site. If as you say there has been a recognition of the problem by Holden then there must be a known cause and a solution as to what caused it.I'm unsure how the Financial Ombudsman fits in with this issue because it it not a 'financial' investment type of problem. Have you been in contact with Motor Codes or Trading Standards?

Dont forget to release your caps lock button. Typing in full capitals is recognised as 'shouting' and discourteous.
 

·
Registered
Joined
·
14 Posts
Hi 2012 ltz with the sat nav screen no touch screen fault.if i switch off car with radio on it switches itself off when you remove keys,but my sat nav screen illuminated by itself and went off.i parked car in my garage for 3 days to find battery flat,i boost pack started and all seems well and now the satnav unit working fine(touch wood).all touch screen come back.i seriously feel that the captiva has some sort of electrical fault somewhere.i recently spoke to vauxhall enquiring about price of sat nav unit at £1100+programming and got told they could see that there was 94 on order and chevrolet say there is no fault so wont recall.Edited by: Bertie.1331
 

·
Super Moderator
Joined
·
6,624 Posts
Unfortunately Bertie this troublesome sat nav is something that GM Chevvy have put their head in the sand over and are denying. There are plenty of posts on this subject. I'm pleased to hear yours is working again but whilst not wanting to be a doomsayer it may only be because the weather has cooled down. Mine worked fine in cold weather but once Spring arrived and warmer weather arrived it went into overheat mode and progressively closed down. I've since had mine replaced under extended warranty but should have been recognised by Chevrolet in my opinion. You can find more under search tab 'Multimedia'.

Dont forget to complete your location and add your vehicle details to your footer so that readers know your vehicle on future posts.
 
1 - 7 of 7 Posts
Top