Chevrolet Owners Club banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Just wondering if anyone has had these faults and able to tell me a specific location. I’ve searched the codes and they have 4 possibilities each. Before I have to spend the price of having everything stripped thought I’d take a shot hear to see if anyone knows a general area to look? If it helps to know the rear lights have gone, break lights have gone, the boot/trunk won’t open and a couple other issues that are less important. The codes are
B2585-02
B3867-02
 

·
Super Moderator
Joined
·
7,867 Posts
I've checked the Forum back index Advanced search but these codes do not appear to have been mentioned before.
To answer your question as to a 'specific location' the answer is No! However the definition of both the codes appears to relate to rear parking lamp.
You appear to looked up the codes and established the 'possible' reasons. Start with the simplest ....... a bulb/lamp blowing may incur a fuse failure. Have you checked for a blown bulb and checked fuses ?? Then test relay.
To have a grouped failure of rear end functions the first basic to check is fuse(s). You dont tell us what basics (if any) you have checked.
The internet descriptions are pretty clear; Blown rear lamp, fuse, relay failure, loose or corroded wiring loom connection, corroded or lose earth connection in the rear lamp area. Body control module problem. Only go BCM as a last resort!

Hanlon, other than the fact that you've posted under the Cruze Forum, you've told us nothing else about your vehicle year/mode/variant etc , nor have you completed your World Sign-Up location. The Forum system believes you may be UK located. There are sections where you can enter this information during Sign-Up. The following link has some helpful information. Helpful Guidance Using the Forum
 
1 - 2 of 2 Posts
Top